Eigenes Script starten, nur wie?

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Eigenes Script starten, nur wie?

      Guten Morgen,

      hab da nochmal 'ne Frage:

      Ich suche unter "/etc/rc.d/start" die ganzen Startscripte, und finde diese leider nirgends.

      Hat sich da die Struktur geändert, oder wie startet die EFW seine Dienste seit der 2.5?

      Aufgefallen ist es mir erst, als ich meine alten Sachen aus der EFW241 in die EFW251
      übernehmen wollte und feststellte, dass keines meiner Scripte aus EFW241 mehr gestartet wird.
      Händisch geht's natürlich schon über /etc/init.d/... start", aber nicht mehr automatisch
      während des Startvorganges.

      Viele Grüße

      Wanninger

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Wanninger ()

    • Re: Init Scripte - wo jetzt?

      Guten Morgen,

      mit ist es halt aufgefallen, als ich das dynaccess Startscript nach /etc/rc.d/start kopierte,
      und nach einem Neustart der Dienst nicht lief, dass irgenwas nicht ganz stimmt.

      Habe es danach auch noch direkt in /etc/rc3.d mit S40dynaccess probiert - lief auch nicht,
      und in den anderen runleveln 2,4,5 wurde das script auch nicht gestartet.

      Eben nur per Hand.

      Das kommt mir etwas seltsam vor.

      Gruß

      Wanninger
    • Re: Init Scripte - wo jetzt?

      Hallo Zusammen,

      also ich komme mit meinem Problem hier einfach nicht weiter.

      Inzwischen habe ich zwar gelernt, dass die einzelnen Dämonen über die "jobsengine"
      gesteuert werden, aber es scheint so, als wäre ich zu doof für diese jobsengine.

      Weder schaffe ich es ein Programm aus dem "rc3.d" noch aus dem "start" zu starten,
      und bei der jobsengine habe auch noch nix gefunden wie diese bedient wird.

      Hat da vielleicht jemand einen heißen Tip für mich?

      Danke und Gruß

      Wanninger
    • Re: Eigenes Script starten, nur wie?

      ...dann geht es uns ja gleich.

      Seit der 2.5 ist das Verzeichnis /etc/rc.d/start leer.
      Auch wenn ich da was reinschreibe (link zu einem irgend einem Startskript) wird nichts gestartet.

      Von Hand starten geht ja, das ist auch nicht das Problem. Das Problem ist halt eben nur dass es
      nicht mehr über den herkömmlichen Weg während des Bootvorganges mit startet.

      Die ganzen laufenden Dienste werden doch seit der 2.5 über die jobsengine gestartet. Nur leider
      finde ich zu dieser keinerlei Info, und ich komme leider auch nicht dahinter, wie diese den Start
      Vorgang macht.

      Alles was bis zur 2.4.1 über /etc/rc.d/start gestartet wurde, stand auch als Link zum Skript drin.
      Seit der 2.5 eben nicht mehr, und trotzdem werden die Dienste gestartet.

      Ist bei Dir das /etc/rc.d/start auch leer?

      Gruß

      Wanninger