*Gelöst* Mail Queue nicht abgearbeitet

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • *Gelöst* Mail Queue nicht abgearbeitet

    Hi,

    aus irgendeinem Grund funktioniert der SMTP Dienst 1h nicht, dann habe ich diesen neugestartet und der Dienst läuft wieder. Jedoch sind in der zwischen Zeit etliche Emails in der Mail Queue (und auch die neuen landen dort) und diese wird nicht abgearbeitet :( . Selbst wenn ich auf "Flush Mail Queue" drücke passiert nix :( . Benötigt amavis etwas Zeit bis wieder alles normal läuft und er die Mail Queue abgearbeitet?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von UserNeo ()

  • Re: *Dringend* Mail Queue nicht abgearbeitet

    Hi,

    es ist viel Spam dabei. Wenn ich den SMTP Proxy Abschalte sollten dann dennoch der MailQueue abgearbeitet werden? Kann man diese auch irgendwo per SSH löschen? Oder wie bekommt man die Emails aus dem MailQueue?

    Es wird abgearbeitet, aber total langsam, jetzt ist er nach 2h erst bei 1300 von ehemals 1600 Mails !?
  • Re: *Dringend* Mail Queue nicht abgearbeitet

    Ja, ist Email Eingang. Der Mail Queue ist jetzt bei 1172 Mails. Wie gesagt es geht aber langsam. Ich werde mal heute abend ein wenig stöbern wenn die Maillast um 70% zurückgeht :D . Wenn du das Verzeichnis kennst wäre das Klasse und danke für deine Hilfe :D
  • Re: *Dringend* Mail Queue nicht abgearbeitet

    Möglich mal das ganze beobachten.

    Muss aber sagen das ich derzeit auch vollgespammt werde,allerdings macht die EFW kein Scan,
    sondern Tobit Server.

    Das einzigste was ich mach ist via efw mails verschicken von div. Applikationen.

    Gruß

    freaky-media
    Kein Support per PN dafür ist das Forum da.
    Preisanfragen via PN möglich oder über freaky-media
  • Re: *Dringend* Mail Queue nicht abgearbeitet

    Hi,

    heute das gleich Problem es haben sich schon wieder 500Mails angestaut und Sie werden nur langsam abgearbeitet. Liegt es eventuell daran das die Spamserver nicht erreichbar sind? Solche Meldungen bekomme ich sehr viele:

    Quellcode

    1. Jul 23 14:18:44 postfix/smtpd[14435]: warning: 83.134.25.194.zen.spamhaus.org: RBL lookup error: Host or domain name not found. Name service error for name=83.134.25.194.zen.spamhaus.org type=A: Host not found, try again
    2. Jul 23 14:18:44 postfix/smtpd[14516]: connect from aedh167.neoplus.adsl.tpnet.pl[79.186.85.167]
    3. Jul 23 14:18:44 postfix/smtpd[14436]: warning: 5.34.214.85.list.dsbl.org: RBL lookup error: Host or domain name not found. Name service error for name=5.34.214.85.list.dsbl.org type=A: Host not found, try again
    4. Jul 23 14:18:43 postfix/smtpd[16619]: warning: 170.158.212.89.zen.spamhaus.org: RBL lookup error: Host or domain name not found. Name service error for name=170.158.212.89.zen.spamhaus.org type=A: Host not found, try again
    5. Jul 23 14:18:43 postfix/smtpd[13407]: disconnect from unknown[213.147.114.186]
    6. Jul 23 14:18:43 postfix/smtpd[13407]: NOQUEUE: reject: RCPT from unknown[213.147.114.186]: 554 5.7.1 Service unavailable; Client host [213.147.114.186] blocked using bl.spamcop.net; Blocked - see http://www.spamcop.net/bl.shtml?213.147.114.186; from=<carfax1962@INeedBeerMoney.com> to=<bridgmanfku174@domain.xxx> proto=ESMTP helo=<[213.147.114.186]>
    7. Jul 23 14:18:42 postfix/smtpd[13407]: connect from unknown[213.147.114.186]
    8. Jul 23 14:18:42 postfix/smtpd[14862]: NOQUEUE: reject: RCPT from unknown[201.79.191.161]: 554 5.7.1 Service unavailable; Client host [201.79.191.161] blocked using dul.dnsbl.sorbs.net; Dynamic IP Addresses See: http://www.sorbs.net/lookup.shtml?201.79.191.161; from=<LottieZamora@mail15.com> to=<restaurateurrvf4@domain.xxx> proto=SMTP helo=<20179191161.user.veloxzone.com.br>
    9. Jul 23 14:18:41 postfix/smtpd[14163]: disconnect from 93-139-6-65.adsl.net.t-com.hr[93.139.6.65]
    10. Jul 23 14:18:41 postfix/smtpd[14862]: NOQUEUE: reject: RCPT from unknown[201.79.191.161]: 554 5.7.1 Service unavailable; Client host [201.79.191.161]
    11. Jul 23 14:18:40 postfix/smtp[17794]: B3CF91E80076: to=<email@domain.xxx>, relay=192.168.1.120[192.168.1.120]:25, delay=0.17, delays=0.01/0.02/0/0.14, dsn=2.6.0, status=sent (250 2.6.0 <2163D8B0ABAE426E833AAD53A3979DD4@PP245> Queued mail for delivery)
    12. Jul 23 14:18:40 postfix/smtp[17794]: B3CF91E80076: to=<email@domain.xxx>, relay=192.168.1.120[192.168.1.120]:25, delay=0.17, delays=0.01/0.02/0/0.14, dsn=2.6.0, status=sent (250 2.6.0 <2163D8B0ABAE426E833AAD53A3979DD4@PP245> Queued mail for delivery)
    13. Jul 23 14:18:40 postfix/qmgr[3738]: B3CF91E80076: removed
    14. Jul 23 14:18:40 postfix/smtp[17794]: warning: 192.168.1.120[192.168.1.120] offered no supported AUTH mechanisms: 'NTLM'
    Alles anzeigen


    Ansonsten sieht es ganz normal aus.
  • Re: *Dringend* Mail Queue nicht abgearbeitet

    Hallo,

    kann es sein das deine IP auf der Schwarzen Liste steht?


    Das andere mit meldung Domain not Found, kann er den DNS Namen nicht auflösen?

    Ansonnsten schau mal ob Mails die rausgehen gleich hier gesperrt werden spamhaus.org/lookup.lasso

    freaky-media
    Kein Support per PN dafür ist das Forum da.
    Preisanfragen via PN möglich oder über freaky-media
  • Re: *Dringend* Mail Queue nicht abgearbeitet

    Also der Pfad lautet:

    Quellcode

    1. /var/spool/postfix/active/


    Diesen habe ich beobachtet und er arbeitet pro Minute 20 Emails ab. Ebenso habe ich festgestellt das er seit 2 tagen permanent volle CPU Leistung hat :eek: ich glaube daran liegt die langsame Verarbeitung!

    Quellcode

    1. 23326 amavis 18 0 266m 254m 3072 R 41 7.4 1:21.26 amavisd
    2. 23868 amavis 25 0 264m 252m 3000 R 20 7.4 0:25.17 amavisd
    3. 23281 amavis 25 0 266m 254m 3072 R 18 7.4 1:31.65 amavisd
    4. 23298 amavis 25 0 264m 252m 3080 R 17 7.4 1:29.63 amavisd
    5. 22938 amavis 25 0 267m 255m 3076 R 17 7.5 2:15.18 amavisd
    6. 23222 amavis 25 0 265m 253m 3076 R 17 7.4 1:44.58 amavisd
    7. 23220 amavis 19 0 265m 253m 3096 R 15 7.4 1:50.40 amavisd
    8. 3842 dnsmasq 16 0 4044 2916 424 S 14 0.1 61:37.25 dnsmasq
    9. 23243 amavis 25 0 267m 255m 3060 R 8 7.5 1:41.90 amavisd
    10. 23508 amavis 25 0 265m 253m 3080 R 8 7.4 1:11.16 amavisd
    11. 23130 amavis 20 0 266m 254m 3080 R 7 7.4 2:08.00 amavisd
    12. 23495 amavis 23 0 265m 253m 3084 R 7 7.4 1:17.21 amavisd
    13. 3441 root 15 0 90576 71m 1616 S 2 2.1 10:47.50 snort
    14. 4212 ntop 15 0 176m 34m 2152 S 2 1.0 12:27.53 ntop
    15. 20662 postfix 15 0 5684 2900 2236 S 2 0.1 0:00.39 smtpd
    16. 22835 postfix 15 0 5444 2720 2132 S 1 0.1 0:02.23 smtp
    17. 22842 postfix 15 0 5444 2720 2132 S 1 0.1 0:02.08 smtp
    18. 1173 root 15 0 3432 2152 700 S 1 0.1 1:56.32 syslog-ng
    19. 3449 clamav 15 0 125m 72m 1168 S 1 2.1 3:15.65 clamd
    Alles anzeigen


    Ich denke der amavis wird hier ungewöhnlich hoch beansprucht. Der Server ist ein AMD X2 6000+ 4GB RAM und 2x 500GB HDD.
    Bilder
    • cpu-week.png

      77,34 kB, 681×227, 703 mal angesehen
  • Re: *Dringend* Mail Queue nicht abgearbeitet

    Ich habe nur eine IP und eine Netzwerkkarte drin. Ich nutze Endian nur als SMTP Gateway für Spam/AntiVirus. Um die Sicherheit kümmert seine eine seperate Firewall. Im Anhang nochmal die CPU Belastung der letzten 24h. Es beginnt gestern ab ca. 16Uhr und betrifft nur den aktuellen Benutzer.

    PS: Habe alle IP's gecheckt sind alle nicht geblockt.
    Bilder
    • cpu-day.png

      83,05 kB, 681×227, 703 mal angesehen