**gelöst** Webinterface nicht erreichbar

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • **gelöst** Webinterface nicht erreichbar

      Hallo Endianer,

      seit gestern abend ist auf ein Mal das Webinterface meines Endian nicht mehr via Browser erreichbar.
      Seitdem habe ich meinen Client neu gestartet, jedoch ist das Problem beständig und geht offenbar von Endian aus:

      "Unable to connect
      Firefox can't establish a connection to the server at xxxxx.xxxx.xxx.
      - The site could be temporarily unavailable or too busy. Try again in a few moments.
      - If you are unable to load any pages, check your computer's network connection.
      - If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web."

      "Internet Explorer cannot display the webpage
      Most likely causes:
      - You are not connected to the Internet.
      - The website is encountering problems.
      - There might be a typing error in the address."

      Darüber hinaus scheint Endian jedoch weiterhin normal zu funktionieren. Andere Websites kann ich problemlos erreichen, meine Mail wird von Spam gewaschen und ich kann ihn auch problemlos anpingen.

      - Woran kann das liegen?
      - Wie kann ich das beheben (außer mit der Holzhammermethode den ganzen Server neu zu starten, denn ich möchte lernen mit Endian so umzugehen, als wäre mein Testrechner bereits productive)?

      Liebe Grüße
      Tom

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von tomakos ()

    • Re: Webinterface nicht erreichbar

      Hallo Frank!

      "ffischer" schrieb:


      Hast du noch Zugriff wie ssh? Dann starte doch mal den httpd neu via putty ssh Console

      Quellcode

      1. /etc/init.d/httpd restart



      Danke für Deine schnelle Hilfe!
      Ja, der Webserver war abgeschmiert. Vor dem Neustarten habe ich den status abgefragt mit

      Quellcode

      1. /etc/init.d/httpd status

      und es hieß: "httpd dead but pid file exists"

      Nach dem Neustart von httpd ist das Frontend wieder normal erreichbar.
      Woran könnte das liegen, dass der Webserver einfach stirbt? Ist der bekannter Maßen so instabil unter 2.2?

      LG
      Tom
    • Re: Webinterface nicht erreichbar

      Hallo,

      es ist öffters mal vorgekommen das der HTTPD abschmier.
      Welche Version der efw hast du den 2.2 rc Version oder Final oder hast eine Appliance ?

      Du kannst unter /var/log/ beim httpd ob er protokolliert hat was passiert ist und ob villeicht Auflschluss gibt.
      Eigentlich ist es nicht normal das der httpd abschmiert.
      Wie lang läuft die efw derzeit schon?

      gruß Frank

      freaky-media
      Kein Support per PN dafür ist das Forum da.
      Preisanfragen via PN möglich oder über freaky-media
    • Re: Webinterface nicht erreichbar

      Hallo Frank

      "ffischer" schrieb:

      Welche Version der efw hast du den 2.2 rc Version oder Final oder hast eine Appliance ?

      2.2 Final Community

      "ffischer" schrieb:

      Du kannst unter /var/log/ beim httpd ob er protokolliert hat was passiert ist und ob villeicht Auflschluss gibt.

      Also der letzte Eintrag vor dem Neustart heute Mittag war:

      Quellcode

      1. [Wed Jul 29 23:57:02 2009] [error] mod_ssl: Init: (atlantis:10443) Ops, no RSA or DSA server certificate found?!
      2. [Wed Jul 29 23:57:02 2009] [error] mod_ssl: Init: (atlantis:10443) You have to perform a *full* server restart when you added or removed a certificate and/or key file

      "ffischer" schrieb:

      Wie lang läuft die efw derzeit schon?

      Weiß nicht mehr exakt wann der letzte Neustart war, aber da ich die ganze Zeit hier Hardware aufbaue, teste und verändere, kann es sich höchstens höchstens um 32 Stunden uptime handeln.

      LG
      Tom
    • Re: Webinterface nicht erreichbar

      Hallo,

      hmm dieses
      Ops, no RSA or DSA server certificate

      Sieht so aus als wenn da das Zert vom httpd weg ist.
      Aber das verwschwindet nicht so leicht.

      Also früher is mir das auch ab und an mal passiert das der httpd abgeschmiert ist aber seit der 2.2Final hab ich derzeit ein uptime dank USV von 62Tagen.

      freaky-media
      Kein Support per PN dafür ist das Forum da.
      Preisanfragen via PN möglich oder über freaky-media
    • Re: Webinterface nicht erreichbar

      Verstehe, ich werde es einfach mal beobachten und schauen wie sich mein neuer Endian in den folgenden Wochen verhält, sobald ich aufgehört habe ständig daran rumzuspielen :D
      Vielelicht habe ich da irgendwas durch mein dauerndes Starten- und Stoppen von Diensten zerschossen...

      Danke für Deine Hilfe, Frank!!

      Gruß
      Tom