Problem mit Portfreigabe/NAT (2.3 final)

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Problem mit Portfreigabe/NAT (2.3 final)

      Hallo beisammen,

      so langsam habe ich den Eindruck, dass die Version 2.3 bislang alles andere als "final" ist. Das dritte Problem, welches ich nicht behoben bekomme ist, dass Portfreigaben nicht funktionieren. Ich habe das Vorgehen mehrfach wiederholt und mit den Schritten bei der 2.2er Version verglichen. Bei der alten Firewall ging es, bei der Neuen nicht. Hier nun mein Vorgehen:

      Ziel: Port 81 von ROT auf Port 80 des Webservers in Orange umleiten
      Problem: Endian macht nichts.
      Nach einer frischen Installation habe ich SSH aktiviert und das Netzwerk eingerichtet , also rot, grün, orange und blau ein eigenes Subnetz gegeben. Der Webserver erwartet Verbindungen im orangen Netzwerk und lässt sich von Endian anpingen.
      Unter Firewall -> NAT -> DNAT -> "neue DNAT Regel hinzufügen" habe ich folgende Einstellungen vorgenommen:
      Zugriff von: Alle
      Ziel: Jeder Uplink
      Richtlinie: Gesatten mit IPS
      Dienst: Benutzerdefiniert
      Protokoll: TCP
      Ziel Port: 81
      Übersetze zu Typ: IP
      DNAT-Richtlinie: NAT
      IP: IP des Webservers
      Port: 80
      und natürlich aktiviert

      Leider ist bei der Firewall Schluss und es wird nichts weitergeleitet. Ich habe sie bereits mehrfach neuinstalliert und neugestartet, aber jedes Mal mit dem selben Effekt. Hier bin ich mit meinem Latein am Ende!

      Grüße Max
    • Re: Problem mit Portfreigabe/NAT (2.3 final)

      also portweiterleitung mit umbiegung geht

      Firewall --> Portweiterleitung / NAT --> Destination NAT --> Neue Destination NAT Regel hinzufügen

      Zugriff von --> Type Zone/VPN/Uplink --> Uplink main
      Ziel --> Type Zone/VPN/Uplink --> Uplink main
      Filterrichtlinie --> Gestaten
      Service Port --> Dienst --> Benutzerdefiniert
      Protokoll --> TCP
      Port --> 81

      Übersetze zu --> IP
      DNAT Richtlinie --> NAT

      IP einfügen --> 192.168.80.2
      Port/Bereich --> 80

      und geht sowol Nmap zeig an das der port offen ist als auch ein aufruf der der ip:port geht

      Gruß Preussal
      [url]http://xen-admin.de[/url]
    • Re: Problem mit Portfreigabe/NAT (2.3 final)

      Hallo Preussal,

      danke für deinen Tipp! Allerdings entspricht meine Einstellung genau der, die du vorschlägst.

      Ich habe allerdings gerade eben selbst eine Entdeckung gemacht:

      Ich wollte die neue Firewall erst mal zusätzlich zur Alten installieren und habe deshalb nur die Firewall konfiguriert. Die Gateways der Server im Orangen Netz sind also gleich geblieben. -> so funktioniert nix.
      Wenn ich nun aber den Gateway der Server auf die neue Firewall ändere, funktioniert die Portweiterleitung!

      Kann sich jemand dieses Verhalten erklären?

      Grüße Max
    • Re: Problem mit Portfreigabe/NAT (2.3 final)

      hmm.

      das wird dann daran liegen das die andere Firewall / gateway die verbindung nicht kennt und deswegen eine Antwort ablehnt.

      zumindest hatte ich auch schon mal so ein Gateway Problem aber da lag es daran das der Server 2 gateways hatte.
      [url]http://xen-admin.de[/url]