**gelöst** Quality of Service

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • **gelöst** Quality of Service

      Quality of Service geht ned bekomme wiedermal die fehlermeldung.

      Quellcode

      1. 500 Internal error
      2. The server encountered an unexpected condition which prevented it from fulfilling the request.
      3. Powered by CherryPy 2.3.0


      bei der 2.3 rc1 hatte ich das Problem auch schon.
      Logfiles hab ich dazu noch keine gefunden.
      [url]http://xen-admin.de[/url]

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Preussal ()

    • Re: Quality of Service

      fehler gefunden

      wenn man ein VPN Client einrichtet dann kann man den QOS nicht mehr konfigurieren.

      in der shell kommt folgende Fehlermeldung wenn man den QOS neustartet

      Quellcode

      1. root@firewall:/ # restartqos.py
      2. Traceback (most recent call last):
      3. File "/usr/local/bin/restartqos.py", line 26, in ?
      4. setup()
      5. File "/usr/lib/python2.4/site-packages/endian/qos/commands.py", line 8, in setup
      6. File "/usr/lib/python2.4/site-packages/endian/qos/qos.py", line 47, in __init__
      7. File "/usr/lib/python2.4/site-packages/endian/core/niclist.py", line 337, in getNicList
      8. File "/usr/lib/python2.4/site-packages/endian/core/niclist.py", line 293, in getVPNs
      9. File "/usr/lib/python2.4/site-packages/endian/data/ds.py", line 23, in __getitem__
      10. KeyError: "'VPN' in 'openvpnclients'"


      verschiebt man nun das den VPN Client "VPN bei mir " aus /var/efw/openvpnclients raus kann man QOS wieder konfigurieren.

      sollte mal geprüft werden an was das liegt.
      leider ist mein pyton ned gut genug um da den fehler zu finden.

      beim neustart der FW macht das auch Probleme hab ich gerade festgestellt.
      [url]http://xen-admin.de[/url]
    • Re: Quality of Service

      Hi,

      ich hatte das gleiche Problem mit dem Fehler 500. Hatte dann in der Bugliste einen hinweise gefunden der den Fehler bei mir behoben hat.

      Das Problem wird offensichtlich verursacht durch Grossbuchstaben in einer angelegten VPN Verbindung.

      Lösung ist/war umbenennen über die Console, oder entsprechende Neuanlage.

      wodix
    • Re: Quality of Service

      Hallo,

      ja das ist gut möglich.
      Bei einer letzten Schulung/Einweisung wurde dieses auch mal genannt das man sogar bei den RED Verbindungsnamen nur Kleinbuchstaben verwenden soll und keine Sonderzeichen nutzen sollte.Da dies wohl zu unvorhergesehenen Problemen führen kann.

      ich hab mir angewöhnt in der EFW alles "klein" zu schreiben.

      gruß Frank

      freaky-media
      Kein Support per PN dafür ist das Forum da.
      Preisanfragen via PN möglich oder über freaky-media