Asrock A330GC mit RL8111DL ??

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Asrock A330GC mit RL8111DL ??

    Ich betreibe die EFW-com 2.3 final auf einem P3 800 und wollte jetzt umstellen auf das Asrock Board mit Atom 330, NB 945GC SB ICH7 und Realtek RTL8111DL.

    Ich schaffe es nicht die RTL8111 zum laufen zu bringen (auch nicht mit selbst kompil. Modul)

    Hat jemand ähnliche oder positive Erfahrungen gemacht?
  • Re: Asrock A330GC mit RL8111DL ??

    So Problem teilweise gelöst !

    Mein Module, das ich mir gebaut hatte läuft soweit, das Problem lag an dem Asrock Board.

    Aus irgendeinem Grund hatte sich der Chipsatz "verschluckt".

    Testweise hatte ich WinXP installiert und mit den Asrock treibern lief das Board. Also Hardware O.K.
    Weder mit FreeBSD noch Knoppix wurde die Schnittstelle erkannt (lspci lieferte keinen Realtek Chip, nur meine 3com Karte).

    Nach einem "Clear CMOS" (Verzweifelungstat) wurde der Chip erkannt. Dieser Fehler ist reproduzierbar mit jeder Neuinstallation der EFW 2.3 von der Community CD. Wahrscheinlich liegt das an dem fehlerhaften Treiber für r8169, der irrtümlicherweise geladen wird.

    Nun kann ich allerdings keinen connect aufbauen :mad:
  • Re: Asrock A330GC mit RL8111DL ??

    ... kein connect: Während des Bootens hat die Onboardnetzschnittstelle (Realtek 8111DL) Verbindung (connect am Ethernetswitch). Während ethconfig läuft unterbricht die Verbindung laut Switch und dann ist Ruhe. ethtool gibt auch aus, dass es keine Verbindung gibt. lspci listet den Chip.

    (Das Modul für den RTL8111/8168 habe ich mit dem aktuellen Treiber von der Realtek Website kompiliert und habe auch ein fertiges Kompilat einer älteren Version aus einer Internetquelle für meine Tests/Versuche vewrwendet)

    Als funktionierendes Interface läuft die 3c905.

    Suche geht weiter ...

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von minti ()

  • Re: Asrock A330GC mit RL8111DL ??

    Dann wird es wohl am Treiber liegen, wir hatten auch mal ein Problem beim Intel Chip, der sich überhaupt nicht mit dem Switch am anderen Ende des Kabels über die Geschwindigkeit einig wurde. Stell die Geschwindigkeit mal fest ein und guck was nach einem Reboot macht...
  • Re: Asrock A330GC mit RL8111DL ??

    "minti" schrieb:

    ... jetzt arbeite ich an einem Workaround:

    Ich werde die astaro-Firewall testen.


    Viel Spaß. Solche Teile tausche ich gerade gegen Endian-Firewalls aus. Die Kunden freuen sich alle...

    Ich habe die deutsche Übersetzung der Endian Firewall verbrochen ;)
  • Re: Asrock A330GC mit RL8111DL ??

    "jeti-power" schrieb:

    Servus,

    ansonsten hättest du einfach nur das richtige Kernelmodul für den Chip selber kompilieren können und das falsch erkannte Modul blacklisten (siehe hier).

    Gruß,
    jeti-power



    Danke für den Hinweis, aber wenn Du mehr als nur den letzten Beitrag von mir in diesem Thread gelesen hättest, wüßtest Du, das ich mir das richtige Kernelmodul kompiliert habe (was nicht geschrieben steht: sogar mehrere Versionen von alt bis zum aktuellen). Im von Dir genannten Beitrag war auf dem Board der RTL8111C Chip verbaut (mit dem es scheinbar funkt.), wohingegen ich auf meinem Board den RTL8111DL verbaut habe. Gleicher Treiber, mehr Features. Da funkt. diese Vorgehensweise nicht mehr.

    Ein aktuelles Ubuntu läuft einwandfrei und bindet das aktuelle Treiber Module für den RTL8169 ein. Dieser aktuelle Treiber (realtek webpage) läßt sich nicht fehlerfrei auf der efw kompilieren und dessen Version in der efw 2.3 läßt den Chip 8111dl völlig verstummen (keine Erkennung mit lspci) ...


    Nochmal danke für Deinen Hinweis ;)