Problem mit Installation SATA Festplatte

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Problem mit Installation SATA Festplatte

      Hallo,

      bei der Installation der EFW 2.3 gibt es erhebliche Probleme mit der Festplatte, es handelt sich dabei um eine SSD, die an einem Intel AHCI Controller angeschlossen ist. Im "enhanced" mode AHCI wurde von EFW keine Festplatte erkannt. Im "Compatible" IDE Mode wurde zwar die Platte /dev/hda gefunden, dafür aber ohne DMA.

      Ein Defekt der HW kann nicht vorliegen, mit Debian Lenny und auch Centos 5.4 wurden in allen Fällen die Festplatten erkannt, im IDE Mode wurde auch DMA aktiviert und die Performance entsprach auch meinen Erwartungen.

      Habe ich etwas beim der Installation von EFW falsch gemacht ?

      Die Performance von Plattenzugriffen macht EFW absolut unbrauchbar.

      Viele Grüße
      Christian
    • Re: Problem mit Installation SATA Festplatte [gelöst]

      Man sollte dem Install Tool einfach nicht unbegrenzt vertrauen. Alt-F3 und dann auf der Shell ein modprobe ahci" hat das Problem gelöst. EFW ist jetzt um mehrere 10er Potenzen schneller geworden :)

      Im BIOS muss natürlich auch AHCI aktiviert werden. Wenn man allerdings kein modprobe macht, dann findet der Installer überhaupt keine Festplatte und bricht ab.

      Es lag auch nicht an der Kernel Version, CentOS / RedHat haben Kernel 2.6.18, also noch älter und da läuft AHCI auch problemlos.